Рекомендация Debian по безопасности

DSA-4472-1 expat -- обновление безопасности

Дата сообщения:
28.06.2019
Затронутые пакеты:
expat
Уязвим:
Да
Ссылки на базы данных по безопасности:
В системе отслеживания ошибок Debian: Ошибка 931031.
В каталоге Mitre CVE: CVE-2018-20843.
Более подробная информация:

Было обнаружено, что Expat, библиотека языка C для выполнения грамматического разбора XML, неправильно обрабатывает входные данные в формате XML, включающие XML-имена, содержащие большое число двоеточий, что потенциально приводит к отказу в обслуживании.

В стабильном выпуске (stretch) эта проблема была исправлена в версии 2.2.0-2+deb9u2.

Рекомендуется обновить пакеты expat.

С подробным статусом поддержки безопасности expat можно ознакомиться на соответствующей странице отслеживания безопасности по адресу https://security-tracker.debian.org/tracker/expat