Aviso de seguridad de Debian

DSA-4475-1 openssl -- actualización de seguridad

Fecha del informe:
1 de jul de 2019
Paquetes afectados:
openssl
Vulnerable:
Referencias a bases de datos de seguridad:
En el diccionario CVE de Mitre: CVE-2019-1543.
Información adicional:

Joran Dirk Greef descubrió que valores de un solo uso («nonces») excesivamente grandes usados con ChaCha20-Poly1305 se procesaban incorrectamente, lo que podía dar lugar a que se reutilizaran. Esto no afecta a usos de ChaCha20-Poly1305 internos al propio OpenSSL, como, por ejemplo, a TLS.

Para la distribución «estable» (stretch), este problema se ha corregido en la versión 1.1.0k-1~deb9u1. Este DSA actualiza también openssl1.0 (que no está afectado por CVE-2019-1543) a 1.0.2s-1~deb9u1.

Le recomendamos que actualice los paquetes de openssl.

Para información detallada sobre el estado de seguridad de openssl, consulte su página en el sistema de seguimiento de problemas de seguridad: https://security-tracker.debian.org/tracker/openssl