Debians sikkerhedsbulletin

DSA-4477-1 zeromq3 -- sikkerhedsopdatering

Rapporteret den:
8. jul 2019
Berørte pakker:
zeromq3
Sårbar:
Ja
Referencer i sikkerhedsdatabaser:
I Mitres CVE-ordbog: CVE-2019-13132.
Yderligere oplysninger:

Fang-Pen Lin opdagede en stakbaseret bufferoverløbsfejl i ZeroMQ, et letvægtsbeskedbibliotek til kernen. En fjern, uautoriseret klient, som forbinder sig til en applikation, der anvender biblioteket libzmq, der kører med en socket der lytter med aktiveret CURVE-kryptering/-autenticikation, kunne drage nytte af fejlen til at forårsage et lammelsesangreb eller udførelse af vilkårlig kode.

I den gamle stabile distribution (stretch), er dette problem rettet i version 4.2.1-4+deb9u2.

I den stabile distribution (buster), er dette problem rettet i version 4.3.1-4+deb10u1.

Vi anbefaler at du opgraderer dine zeromq3-pakker.

For detaljeret sikkerhedsstatus vedrørende zeromq3, se dens sikkerhedssporingssidede på: https://security-tracker.debian.org/tracker/zeromq3