데비안 보안 권고

DSA-4477-1 zeromq3 -- 보안 업데이트

보고일:
2019년 07월 08일
영향 받는 패키지:
zeromq3
위험성:
보안 데이터베이스 참조:
Mitre의 CVE 사전: CVE-2019-13132.
추가 정보:

Fang-Pen Lin discovered a stack-based buffer-overflow flaw in ZeroMQ, a lightweight messaging kernel library. A remote, unauthenticated client connecting to an application using the libzmq library, running with a socket listening with CURVE encryption/authentication enabled, can take advantage of this flaw to cause a denial of service or the execution of arbitrary code.

옛 안정 배포(stretch)에서, 이 문제를 버전 4.2.1-4+deb9u2에서 고쳤습니다.

안정 배포(buster)에서, 이 문제를 버전 4.3.1-4+deb10u1에서 고쳤습니다.

zeromq3 패키지를 업그레이드 하는 게 좋습니다.

zeromq3의 자세한 보안 상태는 보안 추적 페이지 참조: https://security-tracker.debian.org/tracker/zeromq3