Рекомендация Debian по безопасности

DSA-4477-1 zeromq3 -- обновление безопасности

Дата сообщения:
08.07.2019
Затронутые пакеты:
zeromq3
Уязвим:
Да
Ссылки на базы данных по безопасности:
В каталоге Mitre CVE: CVE-2019-13132.
Более подробная информация:

Фан-Пэнь Линь обнаружил переполнение буфера в ZeroMQ, лёгкой библиотеке обмена сообщениями. Удалённый неаутентифицированный клиент, подключающийся к приложению, использующему библиотеку libzmq, запущенную с прослушиванием сокета с включённой поддержкой шифрования/аутентификации CURVE, может использовать эту уязвимость для вызова отказа в обслуживании или выполнения произвольного кода.

В предыдущем стабильном выпуске (stretch) эта проблема была исправлена в версии 4.2.1-4+deb9u2.

В стабильном выпуске (buster) эта проблема была исправлена в версии 4.3.1-4+deb10u1.

Рекомендуется обновить пакеты zeromq3.

С подробным статусом поддержки безопасности zeromq3 можно ознакомиться на соответствующей странице отслеживания безопасности по адресу https://security-tracker.debian.org/tracker/zeromq3