데비안 보안 권고

DSA-4481-1 ruby-mini-magick -- 보안 업데이트

보고일:
2019년 07월 13일
영향 받는 패키지:
ruby-mini-magick
위험성:
보안 데이터베이스 참조:
데비안 버그 추적 시스템: 버그 931932.
Mitre의 CVE 사전: CVE-2019-13574.
추가 정보:

Harsh Jaiswal discovered a remote shell execution vulnerability in ruby-mini-magick, a Ruby library providing a wrapper around ImageMagick or GraphicsMagick, exploitable when using MiniMagick::Image.open with specially crafted URLs coming from unsanitized user input.

옛 안정배포(stretch)에서, 이 문제를 버전 4.5.1-1+deb9u1에서 고쳤습니다.

안정배포(buster)에서, 이 문제를 버전 4.9.2-1+deb10u1에서 고쳤습니다.

ruby-mini-magick 패키지를 업그레이드하는 게 좋습니다.

ruby-mini-magick의 자세한 보안 상태는 보안 추적 페이지 참조: https://security-tracker.debian.org/tracker/ruby-mini-magick