Säkerhetsbulletin från Debian

DSA-4481-1 ruby-mini-magick -- säkerhetsuppdatering

Rapporterat den:
2019-07-13
Berörda paket:
ruby-mini-magick
Sårbara:
Ja
Referenser i säkerhetsdatabaser:
I Debians felrapporteringssystem: Fel 931932.
I Mitres CVE-förteckning: CVE-2019-13574.
Ytterligare information:

Harsh Jaiswal upptäckte en sårbarhet för fjärrkodsexekvering i ruby-mini-magick, ett Ruby-bibliotek som tillhandahåller en wrapper runt ImageMagick eller GraphicsMagick, exploaterbar vid användning av MiniMagick::Image.open med speciellt skapade URLer som kommer från icke rengjord användarindata.

För den gamla stabila utgåvan (Stretch) har detta problem rättats i version 4.5.1-1+deb9u1.

För den stabila utgåvan (Buster) har detta problem rättats i version 4.9.2-1+deb10u1.

Vi rekommenderar att ni uppgraderar era ruby-mini-magick-paket.

För detaljerad säkerhetsstatus om ruby-mini-magick vänligen se dess säkerhetsspårare på https://security-tracker.debian.org/tracker/ruby-mini-magick