Рекомендация Debian по безопасности

DSA-4490-1 subversion -- обновление безопасности

Дата сообщения:
01.08.2019
Затронутые пакеты:
subversion
Уязвим:
Да
Ссылки на базы данных по безопасности:
В каталоге Mitre CVE: CVE-2018-11782, CVE-2019-0203.
Более подробная информация:

В Subversion, системе управления версиями, было обнаружено несколько уязвимостей. Проект Common Vulnerabilities and Exposures определяет следующие проблемы:

  • CVE-2018-11782

    Аце Ольсовка сообщил, что серверный процесс Subversion svnserve может выполнить выход, если обработка правильно сформированного запроса для чтения приводит к определённому ответу, что приводит к отказу в обслуживании.

  • CVE-2019-0203

    Томас Бортоли сообщил, что серверный процесс Subversion svnserve может выполнить выход, если клиент отправляет определённую последовательность протокольны команд. Если на сервере включён анонимный доступ, то это может приводить к отказу в обслуживании, вызываемому удалённым неаутентифицированным пользователем.

В предыдущем стабильном выпуске (stretch) эти проблемы были исправлены в версии 1.9.5-1+deb9u4.

В стабильном выпуске (buster) эти проблемы были исправлены в версии 1.10.4-1+deb10u1.

Рекомендуется обновить пакеты subversion.

С подробным статусом поддержки безопасности subversion можно ознакомиться на соответствующей странице отслеживания безопасности по адресу https://security-tracker.debian.org/tracker/subversion