Aviso de seguridad de Debian

DSA-4496-1 pango1.0 -- actualización de seguridad

Fecha del informe:
11 de ago de 2019
Paquetes afectados:
pango1.0
Vulnerable:
Referencias a bases de datos de seguridad:
En el sistema de seguimiento de errores de Debian: error 933860.
En el diccionario CVE de Mitre: CVE-2019-1010238.
Información adicional:

Benno Fuenfstueck descubrió que Pango, una biblioteca para composición y visualización de texto con énfasis en la traducción a distintos idiomas, es propenso a un defecto de desbordamiento de memoria dinámica («heap») en la función pango_log2vis_get_embedding_levels. Un atacante puede aprovechar este defecto para provocar denegación de servicio o, potencialmente, ejecución de código arbitrario.

Para la distribución «estable» (buster), este problema se ha corregido en la versión 1.42.4-7~deb10u1.

Le recomendamos que actualice los paquetes de pango1.0.

Para información detallada sobre el estado de seguridad de pango1.0, consulte su página en el sistema de seguimiento de problemas de seguridad: https://security-tracker.debian.org/tracker/pango1.0