Debians sikkerhedsbulletin

DSA-4528-1 bird -- sikkerhedsopdatering

Rapporteret den:
19. sep 2019
Berørte pakker:
bird
Sårbar:
Ja
Referencer i sikkerhedsdatabaser:
I Mitres CVE-ordbog: CVE-2019-16159.
Yderligere oplysninger:

Daniel McCarney opdagede at internetroutingdæmonen BIRD på ukorrekt vis validerede RFC 8203-meddelelser i sin BGP-dæmon, medføre et stakbufferoverløb.

I den stabile distribution (buster), er dette problem rettet i version 1.6.6-1+deb10u1. Desuden retter opdateringen en ufuldstændig tilbagekaldelse af rettigheder samt et nedbrud, der kunne udløses via CLI'en (sidstnævnte to fejl er også rettet i den gamle stabile distribution (stretch), som ikke er påvirket af CVE-2019-16159).

Vi anbefaler at du opgraderer dine bird-pakker.

For detaljeret sikkerhedsstatus vedrørende bird, se dens sikkerhedssporingsside på: https://security-tracker.debian.org/tracker/bird