Bulletin d'alerte Debian

DSA-4528-1 bird -- Mise à jour de sécurité

Date du rapport :
19 septembre 2019
Paquets concernés :
bird
Vulnérabilité :
Oui
Références dans la base de données de sécurité :
Dans le dictionnaire CVE du Mitre : CVE-2019-16159.
Plus de précisions :

Daniel McCarney a découvert que le démon de routage internet BIRD ne validait pas correctement les messages RFC 8203 dans son démon BGP, avec pour conséquence un dépassement de tampon de pile.

Pour la distribution stable (Buster), ce problème a été corrigé dans la version 1.6.6-1+deb10u1. En complément, cette mise à jour corrige une révocation incomplète de privilèges et un plantage déclenchable à l'aide de l'interface en ligne de commande (ces deux derniers bogues sont aussi corrigés dans la distribution oldstable (Stretch) qui n'est pas affectée par CVE-2019-16159).

Nous vous recommandons de mettre à jour vos paquets bird.

Pour disposer d'un état détaillé sur la sécurité de bird, veuillez consulter sa page de suivi de sécurité à l'adresse : https://security-tracker.debian.org/tracker/bird.