Рекомендация Debian по безопасности

DSA-4528-1 bird -- обновление безопасности

Дата сообщения:
19.09.2019
Затронутые пакеты:
bird
Уязвим:
Да
Ссылки на базы данных по безопасности:
В каталоге Mitre CVE: CVE-2019-16159.
Более подробная информация:

Дэниель Маккарни обнаружил, что служба маршрутизации BIRD неправильно выполняет проверку сообщений в формате RFC 8203 в своей службе BGP, что приводит к переполнению буфера.

В стабильном выпуске (buster) эта проблема была исправлена в версии 1.6.6-1+deb10u1. Кроме того, данное обновление исправляет неполный отзыв привилегий и аварийную остановку, вызываемую через интерфейс командной строки (эти две ошибки были исправлены и в предыдущем стабильном выпуске (stretch), который не подвержен CVE-2019-16159).

Рекомендуется обновить пакеты bird.

С подробным статусом поддержки безопасности bird можно ознакомиться на соответствующей странице отслеживания безопасности по адресу https://security-tracker.debian.org/tracker/bird