Säkerhetsbulletin från Debian

DSA-4528-1 bird -- säkerhetsuppdatering

Rapporterat den:
2019-09-19
Berörda paket:
bird
Sårbara:
Ja
Referenser i säkerhetsdatabaser:
I Mitres CVE-förteckning: CVE-2019-16159.
Ytterligare information:

Daniel McCarney upptäckte att internetrouting-demonen BIRD validerade RFC 8203-meddelanden felaktigt i BGP-demonen, vilket resulterar i stackbufferspill.

För den stabila utgåvan (Buster) har detta problem rättats i version 1.6.6-1+deb10u1. Utöver detta rättar denna uppdatering ett ofullständigt återkallande av rättigheter och en krasch som är triggningsbar via CLI (dom senare två felen är även rättade i den gamla stabila utgåvan (Stretch) som inte påverkas av CVE-2019-16159).

Vi rekommenderar att ni uppgraderar era bird-paket.

För detaljerad säkerhetsstatus om bird vänligen se dess säkerhetsspårare på https://security-tracker.debian.org/tracker/bird