Debians sikkerhedsbulletin

DSA-4530-1 expat -- sikkerhedsopdatering

Rapporteret den:
22. sep 2019
Berørte pakker:
expat
Sårbar:
Ja
Referencer i sikkerhedsdatabaser:
I Debians fejlsporingssystem: Fejl 939394.
I Mitres CVE-ordbog: CVE-2019-15903.
Yderligere oplysninger:

Man opdagede at Expat, et XML-fortolkningsbibliotek i C, ikke på korrekt vis håndterede interne entitet som afslutter doctype, potentielt medførende lammelsesangreb eller informationsafsløring, hvis en misdannet XML-fil blev behandlet.

I den gamle stabile distribution (stretch), er dette problem rettet i version 2.2.0-2+deb9u3.

I den stabile distribution (buster), er dette problem rettet i version 2.2.6-2+deb10u1.

Vi anbefaler at du opgraderer dine expat-pakker.

For detaljeret sikkerhedsstatus vedrørende expat, se dens sikkerhedssporingssidede på: https://security-tracker.debian.org/tracker/expat