Debians sikkerhedsbulletin

DSA-4534-1 golang-1.11 -- sikkerhedsopdatering

Rapporteret den:
27. sep 2019
Berørte pakker:
golang-1.11
Sårbar:
Ja
Referencer i sikkerhedsdatabaser:
I Mitres CVE-ordbog: CVE-2019-16276.
Yderligere oplysninger:

Man opdagede at programmeringssproget Go accepterede og ikke normaliserede ugyldige HTTP/1.1-headere med et mellemrum før kolonet, hvilket kunne føre til omgåelse af filter eller forespørgselssmugling i nogle opsætninger.

I den stabile distribution (buster), er dette problem rettet i version 1.11.6-1+deb10u2.

Vi anbefaler at du opgraderer dine golang-1.11-pakker.

For detaljeret sikkerhedsstatus vedrørende golang-1.11, se dens sikkerhedssporingsside på: https://security-tracker.debian.org/tracker/golang-1.11