Aviso de seguridad de Debian

DSA-4534-1 golang-1.11 -- actualización de seguridad

Fecha del informe:
27 de sep de 2019
Paquetes afectados:
golang-1.11
Vulnerable:
Referencias a bases de datos de seguridad:
En el diccionario CVE de Mitre: CVE-2019-16276.
Información adicional:

Se descubrió que el lenguaje de programación Go aceptaba y normalizaba cabeceras HTTP/1.1 inválidas con un espacio antes de los dos puntos, lo que podía dar lugar a elusión de filtros o a «contrabando» de peticiones («request smuggling») en algunas configuraciones.

Para la distribución «estable» (buster), este problema se ha corregido en la versión 1.11.6-1+deb10u2.

Le recomendamos que actualice los paquetes de golang-1.11.

Para información detallada sobre el estado de seguridad de golang-1.11, consulte su página en el sistema de seguimiento de problemas de seguridad: https://security-tracker.debian.org/tracker/golang-1.11