Bulletin d'alerte Debian

DSA-4534-1 golang-1.11 -- Mise à jour de sécurité

Date du rapport :
27 septembre 2019
Paquets concernés :
golang-1.11
Vulnérabilité :
Oui
Références dans la base de données de sécurité :
Dans le dictionnaire CVE du Mitre : CVE-2019-16276.
Plus de précisions :

Le langage de programmation Go acceptait et normalisait des en-têtes HTTP/1.1 non valables avec une espace avant les deux points, ce qui pourrait conduire à des contournements de filtre ou à des dissimulations de requête dans certaines configurations.

Pour la distribution stable (Buster), ce problème a été corrigé dans la version 1.11.6-1+deb10u2.

Nous vous recommandons de mettre à jour vos paquets golang-1.11.

Pour disposer d'un état détaillé sur la sécurité de golang-1.11, veuillez consulter sa page de suivi de sécurité à l'adresse : https://security-tracker.debian.org/tracker/golang-1.11.