Säkerhetsbulletin från Debian

DSA-4534-1 golang-1.11 -- säkerhetsuppdatering

Rapporterat den:
2019-09-27
Berörda paket:
golang-1.11
Sårbara:
Ja
Referenser i säkerhetsdatabaser:
I Mitres CVE-förteckning: CVE-2019-16276.
Ytterligare information:

Man har upptäckt att programmeringsspråket Go inte accepterar och normaliserar ogiltiga HTTP/1.1-huvuden med ett mellanslag före kolon, vilket kunde leda till filterförbigång eller förfrågesmuggling i vissa setups.

För den stabila utgåvan (Buster) har detta problem rättats i version 1.11.6-1+deb10u2.

Vi rekommenderar att ni uppgraderar era golang-1.11-paket.

För detaljerad säkerhetsstatus om golang-1.11 vänligen se dess säkerhetsspårare på https://security-tracker.debian.org/tracker/golang-1.11