데비안 보안 권고

DSA-4539-1 openssl -- 보안 업데이트

보고일:
2019년 10월 01일
영향 받는 패키지:
openssl
위험성:
보안 데이터베이스 참조:
Mitre의 CVE 사전: CVE-2019-1547, CVE-2019-1549, CVE-2019-1563.
추가 정보:

Three security issues were discovered in OpenSSL: A timing attack against ECDSA, a padding oracle in PKCS7_dataDecode() and CMS_decrypt_set1_pkey() and it was discovered that a feature of the random number generator (RNG) intended to protect against shared RNG state between parent and child processes in the event of a fork() syscall was not used by default.

For the oldstable distribution (stretch), these problems have been fixed in version 1.1.0l-1~deb9u1.

안정 배포(buster)에서, 이 문제를 버전 1.1.1d-0+deb10u1에서 고침.

openssl 패키지를 업그레이드 하는 게 좋음.

openssl의 자세한 보안 상태는 보안 추적 페이지 참조: https://security-tracker.debian.org/tracker/openssl