Aviso de seguridad de Debian

DSA-4541-1 libapreq2 -- actualización de seguridad

Fecha del informe:
4 de oct de 2019
Paquetes afectados:
libapreq2
Vulnerable:
Referencias a bases de datos de seguridad:
En el sistema de seguimiento de errores de Debian: error 939937.
En el diccionario CVE de Mitre: CVE-2019-12412.
Información adicional:

Max Kellermann informó de un defecto de desreferencia de puntero NULL en libapreq2, una biblioteca para peticiones Apache genéricas, que permitía a un atacante remoto provocar denegación de servicio en una aplicación que utilizara la biblioteca (caída de la aplicación) si se procesaba un cuerpo multiparte anidado inválido.

Para la distribución «antigua estable» (stretch), este problema se ha corregido en la versión 2.13-7~deb9u1.

Para la distribución «estable» (buster), este problema se ha corregido en la versión 2.13-7~deb10u1.

Le recomendamos que actualice los paquetes de libapreq2.

Para información detallada sobre el estado de seguridad de libapreq2, consulte su página en el sistema de seguimiento de problemas de seguridad: https://security-tracker.debian.org/tracker/libapreq2