Bulletin d'alerte Debian

DSA-4541-1 libapreq2 -- Mise à jour de sécurité

Date du rapport :
4 octobre 2019
Paquets concernés :
libapreq2
Vulnérabilité :
Oui
Références dans la base de données de sécurité :
Dans le système de suivi des bogues Debian : Bogue 939937.
Dans le dictionnaire CVE du Mitre : CVE-2019-12412.
Plus de précisions :

Max Kellermann a signalé un défaut de déréférencement de pointeur NULL dans libapreq2, une bibliothèque générique de requêtes Apache, permettant à un attaquant distant de provoquer un déni de service à l'encontre d'une application utilisant la bibliothèque (plantage d'application) lors du traitement d'un corps multipart imbriqué non valable.

Pour la distribution oldstable (Stretch), ce problème a été corrigé dans la version 2.13-7~deb9u1.

Pour la distribution stable (Buster), ce problème a été corrigé dans la version 2.13-7~deb10u1.

Nous vous recommandons de mettre à jour vos paquets libapreq2.

Pour disposer d'un état détaillé sur la sécurité de libapreq2, veuillez consulter sa page de suivi de sécurité à l'adresse : https://security-tracker.debian.org/tracker/libapreq2.