Рекомендация Debian по безопасности

DSA-4543-1 sudo -- обновление безопасности

Дата сообщения:
14.10.2019
Затронутые пакеты:
sudo
Уязвим:
Да
Ссылки на базы данных по безопасности:
В системе отслеживания ошибок Debian: Ошибка 942322.
В каталоге Mitre CVE: CVE-2019-14287.
Более подробная информация:

Джо Венникс обнаружил, что sudo, программа для предоставления ограниченных прав суперпользователя определённым пользователям, настроенная разрешать пользователю запускать команды от лица произвольного пользователя через ключ ALL в спецификации Runas, позволяет запускать команды от лица суперпользователя путём указания пользовательского идентификатора -1 или 4294967295. Это позволяет пользователю с достаточными правами sudo запускать команды от лица суперпользователя даже в случае, когда спецификация Runas явным образом запрещает доступ от лица суперпользователя.

Подробности можно посмотреть в рекомендации основной ветки разработки по адресу https://www.sudo.ws/alerts/minus_1_uid.html.

В предыдущем стабильном выпуске (stretch) эта проблема была исправлена в версии 1.8.19p1-2.1+deb9u1.

В стабильном выпуске (buster) эта проблема была исправлена в версии 1.8.27-1+deb10u1.

Рекомендуется обновить пакеты sudo.

С подробным статусом поддержки безопасности sudo можно ознакомиться на соответствующей странице отслеживания безопасности по адресу https://security-tracker.debian.org/tracker/sudo