Debians sikkerhedsbulletin

DSA-4550-1 file -- sikkerhedsopdatering

Rapporteret den:
25. okt 2019
Berørte pakker:
file
Sårbar:
Ja
Referencer i sikkerhedsdatabaser:
I Mitres CVE-ordbog: CVE-2019-18218.
Yderligere oplysninger:

Et bufferoverløb blev fundet i file, et værktøj til klassificering af filtyper, hvilket kunne medføre lammelsesangreb eller potentielt udførelse af vilkårlig kode, hvis en misdannet CDF-fil (Composite Document File) blev behandlet.

I den gamle stabile distribution (stretch), er dette problem rettet i version 1:5.30-1+deb9u3.

I den stabile distribution (buster), er dette problem rettet i version 1:5.35-4+deb10u1.

Vi anbefaler at du opgraderer dine file-pakker.

For detaljeret sikkerhedsstatus vedrørende file, se dens sikkerhedssporingsside på: https://security-tracker.debian.org/tracker/file