Bulletin d'alerte Debian

DSA-4555-1 pam-python -- Mise à jour de sécurité

Date du rapport :
29 octobre 2019
Paquets concernés :
pam-python
Vulnérabilité :
Oui
Références dans la base de données de sécurité :
Dans le dictionnaire CVE du Mitre : CVE-2019-16729.
Plus de précisions :

Malte Kraus a découvert que libpam-python, un module PAM permettant d'écrire des modules PAM en Python, ne vérifiait pas les variables d'environnement ce qui pourrait avoir pour conséquence une élévation locale de privilèges lors de son utilisation avec un binaire setuid.

Pour la distribution oldstable (Stretch), ce problème a été corrigé dans la version 1.0.6-1.1+deb9u1.

Pour la distribution stable (Buster), ce problème a été corrigé dans la version 1.0.6-1.1+deb10u1.

Nous vous recommandons de mettre à jour vos paquets pam-python.

Pour disposer d'un état détaillé sur la sécurité de pam-python, veuillez consulter sa page de suivi de sécurité à l'adresse : https://security-tracker.debian.org/tracker/pam-python.