Рекомендация Debian по безопасности

DSA-4555-1 pam-python -- обновление безопасности

Дата сообщения:
29.10.2019
Затронутые пакеты:
pam-python
Уязвим:
Да
Ссылки на базы данных по безопасности:
В каталоге Mitre CVE: CVE-2019-16729.
Более подробная информация:

Мальте Краус обнаружил, что libpam-python, PAM-модуль, позволяющий писать PAM-модули на языке Python, не выполняет очистку переменных окружения, что приводит к локальному повышению привилегий в случае использования с двоичным файлом, имеющим setuid-флаг.

В предыдущем стабильном выпуске (stretch) эта проблема была исправлена в версии 1.0.6-1.1+deb9u1.

В стабильном выпуске (buster) эта проблема была исправлена в версии 1.0.6-1.1+deb10u1.

Рекомендуется обновить пакеты pam-python.

С подробным статусом поддержки безопасности pam-python можно ознакомиться на соответствующей странице отслеживания безопасности по адресу https://security-tracker.debian.org/tracker/pam-python