Säkerhetsbulletin från Debian

DSA-4555-1 pam-python -- säkerhetsuppdatering

Rapporterat den:
2019-10-29
Berörda paket:
pam-python
Sårbara:
Ja
Referenser i säkerhetsdatabaser:
I Mitres CVE-förteckning: CVE-2019-16729.
Ytterligare information:

Malte Kraus upptäckte att libpam-python, en PAM-modul som tillåter PAM-moduler att skrivas i Python, inte rengjorde miljövariabler vilket kunde resultera i en lokal utökning av rättigheter om den används tillsammans med en setuid-binär.

För den gamla stabila utgåvan (Stretch) har detta problem rättats i version 1.0.6-1.1+deb9u1.

För den stabila utgåvan (Buster) har detta problem rättats i version 1.0.6-1.1+deb10u1.

Vi rekommenderar att ni uppgraderar era pam-python-paket.

För detaljerad säkerhetsstatus om pam-python vänligen se dess säkerhetsspårare på https://security-tracker.debian.org/tracker/pam-python