Debians sikkerhedsbulletin

DSA-4557-1 libarchive -- sikkerhedsopdatering

Rapporteret den:
31. okt 2019
Berørte pakker:
libarchive
Sårbar:
Ja
Referencer i sikkerhedsdatabaser:
I Mitres CVE-ordbog: CVE-2019-18408.
Yderligere oplysninger:

En anvendelse efter frigivelse blev fundet i libarchive, et bibliotek der understøtter mange arkiveringsformater, hvilket kunne medføre lammelsesangreb og potentielt udførelse af vilkårlig kode, hvis et misdannet arkiv blev behandlet.

I den gamle stabile distribution (stretch), er dette problem rettet i version 3.2.2-2+deb9u2.

I den stabile distribution (buster), er dette problem rettet i version 3.3.3-4+deb10u1.

Vi anbefaler at du opgraderer dine libarchive-pakker.

For detaljeret sikkerhedsstatus vedrørende libarchive, se dens sikkerhedssporingsside på: https://security-tracker.debian.org/tracker/libarchive