Рекомендация Debian по безопасности

DSA-4558-1 webkit2gtk -- обновление безопасности

Дата сообщения:
04.11.2019
Затронутые пакеты:
webkit2gtk
Уязвим:
Да
Ссылки на базы данных по безопасности:
В каталоге Mitre CVE: CVE-2019-8625, CVE-2019-8720, CVE-2019-8769, CVE-2019-8771.
Более подробная информация:

В веб-движке webkit2gtk было обнаружено несколько уязвимостей:

  • CVE-2019-8625

    Сергей Глазунов обнаружил, что специально сформированное веб-содержимое может приводить к универсальному межсайтовому скриптингу.

  • CVE-2019-8720

    Вэнь Сюй обнаружил, что специально сформированное веб-содержимое может приводить к выполнению произвольного кода.

  • CVE-2019-8769

    Пьер Рэмтс обнаружил, что посещение специально сформированного веб-сайта может привести к раскрытию истории просмотра.

  • CVE-2019-8771

    Элия Штайн обнаружил, что специально сформированное веб-содержимое может нарушить правило песочницы для iframe.

В стабильном выпуске (buster) эти проблемы были исправлены в версии 2.26.1-3~deb10u1.

Рекомендуется обновить пакеты webkit2gtk.

С подробным статусом поддержки безопасности webkit2gtk можно ознакомиться на соответствующей странице отслеживания безопасности по адресу https://security-tracker.debian.org/tracker/webkit2gtk