Säkerhetsbulletin från Debian

DSA-4558-1 webkit2gtk -- säkerhetsuppdatering

Rapporterat den:
2019-11-04
Berörda paket:
webkit2gtk
Sårbara:
Ja
Referenser i säkerhetsdatabaser:
I Mitres CVE-förteckning: CVE-2019-8625, CVE-2019-8720, CVE-2019-8769, CVE-2019-8771.
Ytterligare information:

Flera sårbarheter har upptäckts i webbmotorn webkit2gtk:

  • CVE-2019-8625

    Sergei Glazunov upptäckte att illasinnat skapat webbinnehåll kan leda till universellt serveröverskridande skriptning.

  • CVE-2019-8720

    Wen Xu upptäckte att illasinnat skapat webbinnehåll kan leda till godtycklig kodexekvering.

  • CVE-2019-8769

    Pierre Reimertz upptäckte att besök av en illasinnat skapad webbplats kan avslöja webbläsningshistorik.

  • CVE-2019-8771

    Eliya Stein upptäckte att illasinnat skapat webbinnehåll kan bryta policy för skyddsmekanismer för iframe.

För den stabila utgåvan (Buster) har dessa problem rättats i version 2.26.1-3~deb10u1.

Vi rekommenderar att ni uppgraderar era webkit2gtk-paket.

För detaljerad säkerhetsstatus om webkit2gtk vänligen se dess säkerhetsspårare på https://security-tracker.debian.org/tracker/webkit2gtk