주의: 이 번역은 원문보다 오래되었습니다.

데비안 보안 권고

DSA-4570-1 mosquitto -- 보안 업데이트

보고일:
2019년 11월 17일
영향 받는 패키지:
mosquitto
위험성:
보안 데이터베이스 참조:
데비안 버그 추적 시스템: 버그 940654.
Mitre의 CVE 사전: CVE-2019-11779.
추가 정보:

A vulnerability was discovered in mosquitto, a MQTT version 3.1/3.1.1 compatible message broker, allowing a malicious MQTT client to cause a denial of service (stack overflow and daemon crash), by sending a specially crafted SUBSCRIBE packet containing a topic with a extremely deep hierarchy.

For the stable distribution (buster), this problem has been fixed in version 1.5.7-1+deb10u1.

mosquitto 패키지를 업그레이드 하는 게 좋습니다.

For the detailed security status of mosquitto please refer to its security tracker page at: https://security-tracker.debian.org/tracker/mosquitto