Рекомендация Debian по безопасности

DSA-4576-1 php-imagick -- обновление безопасности

Дата сообщения:
25.11.2019
Затронутые пакеты:
php-imagick
Уязвим:
Да
Ссылки на базы данных по безопасности:
В системе отслеживания ошибок Debian: Ошибка 928420.
В каталоге Mitre CVE: CVE-2019-11037.
Более подробная информация:

В php-imagick, расширении для PHP для создания и изменения изображений с помощью API ImageMagick, была обнаружена проблема, приводящая к записи за пределами выделенного буфера памяти, что может приводить к отказу в обслуживании или выполнению произвольного кода.

В предыдущем стабильном выпуске (stretch) эта проблема была исправлена в версии 3.4.3~rc2-2+deb9u1.

Рекомендуется обновить пакеты php-imagick.

С подробным статусом поддержки безопасности php-imagick можно ознакомиться на соответствующей странице отслеживания безопасности по адресу https://security-tracker.debian.org/tracker/php-imagick