Debians sikkerhedsbulletin

DSA-4577-1 haproxy -- sikkerhedsopdatering

Rapporteret den:
28. nov 2019
Berørte pakker:
haproxy
Sårbar:
Ja
Referencer i sikkerhedsdatabaser:
I Mitres CVE-ordbog: CVE-2019-19330.
Yderligere oplysninger:

Tim Düsterhus opdagede at haproxy, en reverse TCP-/HTTP-proxy, ikke på korrekt vis fornuftighedskontrollerede HTTP-header, ved konvertering fra HTTP/2 til HTTP/1. Det kunne gøre det muligt for en fjernbruger, at iværksætte CRLF-indsprøjtning.

I den stabile distribution (buster), er dette problem rettet i version 1.8.19-1+deb10u1.

Vi anbefaler at du opgraderer dine haproxy-pakker.

For detaljeret sikkerhedsstatus vedrørende haproxy, se dens sikkerhedssporingsside på: https://security-tracker.debian.org/tracker/haproxy