Рекомендация Debian по безопасности

DSA-4586-1 ruby2.5 -- обновление безопасности

Дата сообщения:
17.12.2019
Затронутые пакеты:
ruby2.5
Уязвим:
Да
Ссылки на базы данных по безопасности:
В каталоге Mitre CVE: CVE-2019-15845, CVE-2019-16201, CVE-2019-16254, CVE-2019-16255.
Более подробная информация:

В интерпретаторе языка Ruby было обнаружено несколько уязвимостей, которые могут приводить к неавторизованному доступу в связи с обходом совпадений предполагаемых путей, отказу в обслуживании или выполнению произвольного кода.

В стабильном выпуске (buster) эти проблемы были исправлены в версии 2.5.5-3+deb10u1.

Рекомендуется обновить пакеты ruby2.5.

С подробным статусом поддержки безопасности ruby2.5 можно ознакомиться на соответствующей странице отслеживания безопасности по адресу https://security-tracker.debian.org/tracker/ruby2.5