Säkerhetsbulletin från Debian

DSA-4586-1 ruby2.5 -- säkerhetsuppdatering

Rapporterat den:
2019-12-17
Berörda paket:
ruby2.5
Sårbara:
Ja
Referenser i säkerhetsdatabaser:
I Mitres CVE-förteckning: CVE-2019-15845, CVE-2019-16201, CVE-2019-16254, CVE-2019-16255.
Ytterligare information:

Flera sårbarheter har upptäckts i tolken för språket Ruby, vilket kunde resultera i icke auktoriserad åtkomst genom att förbigå avsedda sökvägsmatchningar, överbelastning, eller exekvering av godtycklig kod.

För den stabila utgåvan (Buster) har dessa problem rättats i version 2.5.5-3+deb10u1.

Vi rekommenderar att ni uppgraderar era ruby2.5-paket.

För detaljerad säkerhetsstatus om ruby2.5 vänligen se dess säkerhetsspårare på https://security-tracker.debian.org/tracker/ruby2.5