Рекомендация Debian по безопасности

DSA-4588-1 python-ecdsa -- обновление безопасности

Дата сообщения:
17.12.2019
Затронутые пакеты:
python-ecdsa
Уязвим:
Да
Ссылки на базы данных по безопасности:
В каталоге Mitre CVE: CVE-2019-14853, CVE-2019-14859.
Более подробная информация:

Было обнаружено, что python-ecdsa, библиотека поддержки криптографических подписей для Python, неправильно обрабатывает определённые подписи. Удалённый злоумышленник может использовать эту проблему для того, чтобы библиотека python-ecdsa не выводила предупреждение о некорректных подписях, либо порождала исключения, приводящие к отказу в обслуживании.

В предыдущем стабильном выпуске (stretch) эти проблемы были исправлены в версии 0.13-2+deb9u1.

В стабильном выпуске (buster) эти проблемы были исправлены в версии 0.13-3+deb10u1.

Рекомендуется обновить пакеты python-ecdsa.

С подробным статусом поддержки безопасности python-ecdsa можно ознакомиться на соответствующей странице отслеживания безопасности по адресу https://security-tracker.debian.org/tracker/python-ecdsa