Debians sikkerhedsbulletin

DSA-4597-1 netty -- sikkerhedsopdatering

Rapporteret den:
3. jan 2020
Berørte pakker:
netty
Sårbar:
Ja
Referencer i sikkerhedsdatabaser:
I Debians fejlsporingssystem: Fejl 941266.
I Mitres CVE-ordbog: CVE-2019-16869.
Yderligere oplysninger:

Der blev rapporteret, at Netty, et Java NIO-klient/server-framework, var en HTTP-forspørgselssmuglingssårbarhed på grund af fejlhåndteret whitespace før et kolon i HTTP-headere.

I den gamle stabile distribution (stretch), er dette problem rettet i version 1:4.1.7-2+deb9u1.

I den stabile distribution (buster), er dette problem rettet i version 1:4.1.33-1+deb10u1.

Vi anbefaler at du opgraderer dine netty-pakker.

For detaljeret sikkerhedsstatus vedrørende netty, se dens sikkerhedssporingssidede på: https://security-tracker.debian.org/tracker/netty