데비안 보안 권고

DSA-4597-1 netty -- 보안 업데이트

보고일:
2020년 01월 03일
영향 받는 패키지:
netty
위험성:
보안 데이터베이스 참조:
데비안 버그 추적 시스템: 버그 941266.
Mitre의 CVE 사전: CVE-2019-16869.
추가 정보:

It was reported that Netty, a Java NIO client/server framework, is prone to a HTTP request smuggling vulnerability due to mishandling whitespace before the colon in HTTP headers.

For the oldstable distribution (stretch), this problem has been fixed in version 1:4.1.7-2+deb9u1.

안정 배포(buster)에서, 이 문제를 버전 1:4.1.33-1+deb10u1에서 고침.

netty 패키지를 업그레이드 하는 게 좋음.

netty의 자세한 보안 상태는 보안 추적 페이지 참조: https://security-tracker.debian.org/tracker/netty