Рекомендация Debian по безопасности

DSA-4597-1 netty -- обновление безопасности

Дата сообщения:
03.01.2020
Затронутые пакеты:
netty
Уязвим:
Да
Ссылки на базы данных по безопасности:
В системе отслеживания ошибок Debian: Ошибка 941266.
В каталоге Mitre CVE: CVE-2019-16869.
Более подробная информация:

Было сообщено, что Netty, NIO-инфраструктура клиент/сервер для Java, уязвима к подделке HTTP-запросов из-за неправильной обработки разделителей перед двоеточием в заголовках HTTP.

В предыдущем стабильном выпуске (stretch) эта проблема была исправлена в версии 1:4.1.7-2+deb9u1.

В стабильном выпуске (buster) эта проблема была исправлена в версии 1:4.1.33-1+deb10u1.

Рекомендуется обновить пакеты netty.

С подробным статусом поддержки безопасности netty можно ознакомиться на соответствующей странице отслеживания безопасности по адресу https://security-tracker.debian.org/tracker/netty