주의: 이 번역은 원문보다 오래되었습니다.

데비안 보안 권고

DSA-4598-1 python-django -- 보안 업데이트

보고일:
2020년 01월 07일
영향 받는 패키지:
python-django
위험성:
보안 데이터베이스 참조:
데비안 버그 추적 시스템: 버그 946937.
Mitre의 CVE 사전: CVE-2019-19844.
추가 정보:

Simon Charette reported that the password reset functionality in Django, a high-level Python web development framework, uses a Unicode case-insensitive query to retrieve accounts matching the email address requesting the password reset. An attacker can take advantage of this flaw to potentially retrieve password reset tokens and hijack accounts.

For details please refer to https://www.djangoproject.com/weblog/2019/dec/18/security-releases/

For the oldstable distribution (stretch), this problem has been fixed in version 1:1.10.7-2+deb9u7.

For the stable distribution (buster), this problem has been fixed in version 1:1.11.27-1~deb10u1.

python-django 패키지를 업그레이드 하는 게 좋습니다.

python-django의 자세한 보안 상태는 보안 추적 페이지를 참조하십시오: https://security-tracker.debian.org/tracker/python-django