Рекомендация Debian по безопасности

DSA-4598-1 python-django -- обновление безопасности

Дата сообщения:
07.01.2020
Затронутые пакеты:
python-django
Уязвим:
Да
Ссылки на базы данных по безопасности:
В системе отслеживания ошибок Debian: Ошибка 946937.
В каталоге Mitre CVE: CVE-2019-19844.
Более подробная информация:

Симон Шарет сообщил, что возможность сброса пароля в Django, высокоуровневой платформе веб-разработки на Python, использует нечувствительный к регистру запрос в кодировке юникод для получения учётных записей, соответствующи адресу электронной почты, для которого запрошен сброс пароля. Злоумышленник может использовать эту уязвимость для потенциального получения токенов сброса пароля и хищения учётных записей.

За подробностями обращайтесь по адрсу https://www.djangoproject.com/weblog/2019/dec/18/security-releases/

В предыдущем стабильном выпуске (stretch) эта проблема была исправлена в версии 1:1.10.7-2+deb9u7.

В стабильном выпуске (buster) эта проблема была исправлена в версии 1:1.11.27-1~deb10u1.

Рекомендуется обновить пакеты python-django.

С подробным статусом поддержки безопасности python-django можно ознакомиться на соответствующей странице отслеживания безопасности по адресу https://security-tracker.debian.org/tracker/python-django