주의: 이 번역은 원문보다 오래되었습니다.

데비안 보안 권고

DSA-4604-1 cacti -- 보안 업데이트

보고일:
2020년 01월 19일
영향 받는 패키지:
cacti
위험성:
보안 데이터베이스 참조:
데비안 버그 추적 시스템: 버그 947374, 버그 947375, 버그 941036.
Mitre의 CVE 사전: CVE-2019-16723, CVE-2019-17357, CVE-2019-17358.
추가 정보:

Multiple issues have been found in cacti, a server monitoring system, potentially resulting in SQL code execution or information disclosure by authenticated users.

  • CVE-2019-16723

    Authenticated users may bypass authorization checks for viewing a graph by submitting requests with modified local_graph_id parameters.

  • CVE-2019-17357

    The graph administration interface insufficiently sanitizes the template_id parameter, potentially resulting in SQL injection. This vulnerability might be leveraged by authenticated attackers to perform unauthorized SQL code execution on the database.

  • CVE-2019-17358

    The sanitize_unserialize_selected_items function (lib/functions.php) insufficiently sanitizes user input before deserializing it, potentially resulting in unsafe deserialization of user-controlled data. This vulnerability might be leveraged by authenticated attackers to influence the program control flow or cause memory corruption.

For the oldstable distribution (stretch), these problems have been fixed in version 0.8.8h+ds1-10+deb9u1. Note that stretch was only affected by CVE-2018-17358.

For the stable distribution (buster), these problems have been fixed in version 1.2.2+ds1-2+deb10u2.

cacti 패키지를 업그레이드 하는 게 좋습니다.

For the detailed security status of cacti please refer to its security tracker page at: https://security-tracker.debian.org/tracker/cacti