Рекомендация Debian по безопасности

DSA-4607-1 openconnect -- обновление безопасности

Дата сообщения:
20.01.2020
Затронутые пакеты:
openconnect
Уязвим:
Да
Ссылки на базы данных по безопасности:
В системе отслеживания ошибок Debian: Ошибка 940871.
В каталоге Mitre CVE: CVE-2019-16239.
Более подробная информация:

Лукас Купчик сообщил об уязвимости в коде для обработки разбитых на части данных при передаче по протоколу HTTP в openconnect, открытом клиенте для Cisco AnyConnect, Pulse и GlobalProtect VPN. Вредоносный HTTP-сервер (после принятия его удостоверяющего сертификата) может передать поддельное значение длины частей при их передаче по HTTP и тем самым вызвать переполнение буфера.

В предыдущем стабильном выпуске (stretch) эта проблема была исправлена в версии 7.08-1+deb9u1.

В стабильном выпуске (buster) эта проблема была исправлена в версии 8.02-1+deb10u1.

Рекомендуется обновить пакеты openconnect.

С подробным статусом поддержки безопасности openconnect можно ознакомиться на соответствующей странице отслеживания безопасности по адресу https://security-tracker.debian.org/tracker/openconnect