Debians sikkerhedsbulletin

DSA-4611-1 opensmtpd -- sikkerhedsopdatering

Rapporteret den:
29. jan 2020
Berørte pakker:
opensmtpd
Sårbar:
Ja
Referencer i sikkerhedsdatabaser:
I Debians fejlsporingssystem: Fejl 950121.
I Mitres CVE-ordbog: CVE-2020-7247.
Yderligere oplysninger:

Qualys opdagede at OpenSMTPD's SMTP-server udførte utilstrækkelig validering af mailadresser, hvilket kunne medføre udførelse af vilkårlige kommandoer som root. Desuden retter denne opdatering et lammelsesangreb, udløst af en opportunistisk TLS-nedgradering.

I den gamle stabile distribution (stretch), er disse problemer rettet i version 6.0.2p1-2+deb9u2.

I den stabile distribution (buster), er disse problemer rettet i version 6.0.3p1-5+deb10u3. Opdateringen indeholder også fejlrettelser som ikke er sikkerhedsrelaterede, hvilke allerede var gjort klar til busters 10.3-punktopdatering.

Vi anbefaler at du opgraderer dine opensmtpd-pakker.

For detaljeret sikkerhedsstatus vedrørende opensmtpd, se dens sikkerhedssporingsside på: https://security-tracker.debian.org/tracker/opensmtpd