주의: 이 번역은 원문보다 오래되었습니다.

데비안 보안 권고

DSA-4613-1 libidn2 -- 보안 업데이트

보고일:
2020년 02월 01일
영향 받는 패키지:
libidn2
위험성:
보안 데이터베이스 참조:
데비안 버그 추적 시스템: 버그 942895.
Mitre의 CVE 사전: CVE-2019-18224.
추가 정보:

A heap-based buffer overflow vulnerability was discovered in the idn2_to_ascii_4i() function in libidn2, the GNU library for Internationalized Domain Names (IDNs), which could result in denial of service, or the execution of arbitrary code when processing a long domain string.

For the stable distribution (buster), this problem has been fixed in version 2.0.5-1+deb10u1.

libidn2를 업그레이드 하는 게 좋습니다.

For the detailed security status of libidn2 please refer to its security tracker page at: https://security-tracker.debian.org/tracker/libidn2