Aviso de seguridad de Debian

DSA-4619-1 libxmlrpc3-java -- actualización de seguridad

Fecha del informe:
6 de feb de 2020
Paquetes afectados:
libxmlrpc3-java
Vulnerable:
Referencias a bases de datos de seguridad:
En el sistema de seguimiento de errores de Debian: error 949089.
En el diccionario CVE de Mitre: CVE-2019-17570.
Información adicional:

Guillaume Teissier informó de que el cliente XMLRPC de libxmlrpc3-java, una implementación Java de XML-RPC, no reconstruye la excepción del lado servidor serializada en el atributo faultCause de los mensajes de respuesta de error de XMLRPC. Un servidor XMLRPC malicioso puede aprovechar este defecto para ejecutar código arbitrario con los privilegios de una aplicación que utilice la biblioteca cliente XMLRPC de Apache.

Tenga en cuenta que un cliente que espere recibir excepciones del lado servidor necesita establecer la propiedad enabledForExceptions explícitamente.

Para la distribución «antigua estable» (stretch), este problema se ha corregido en la versión 3.1.3-8+deb9u1.

Para la distribución «estable» (buster), este problema se ha corregido en la versión 3.1.3-9+deb10u1.

Le recomendamos que actualice los paquetes de libxmlrpc3-java.

Para información detallada sobre el estado de seguridad de libxmlrpc3-java, consulte su página en el sistema de seguimiento de problemas de seguridad: https://security-tracker.debian.org/tracker/libxmlrpc3-java