Debians sikkerhedsbulletin

DSA-4629-1 python-django -- sikkerhedsopdatering

Rapporteret den:
19. feb 2020
Berørte pakker:
python-django
Sårbar:
Ja
Referencer i sikkerhedsdatabaser:
I Debians fejlsporingssystem: Fejl 950581.
I Mitres CVE-ordbog: CVE-2020-7471.
Yderligere oplysninger:

Simon Charette opdagede at Django, et webudviklingsframework på højt niveau til Python, ikke på korrekt vis håndterede inddata i dets PostgreSQL-modul. En fjernangriber kunne udnytte fejlen til at iværksætte SQL-indsprøjtningsangreb.

I den gamle stabile distribution (stretch), er dette problem rettet i version 1:1.10.7-2+deb9u8.

I den stabile distribution (buster), er dette problem rettet i version 1:1.11.28-1~deb10u1.

Vi anbefaler at du opgraderer dine python-django-pakker.

For detaljeret sikkerhedsstatus vedrørende python-django, se dens sikkerhedssporingsside på: https://security-tracker.debian.org/tracker/python-django