Debians sikkerhedsbulletin

DSA-4630-1 python-pysaml2 -- sikkerhedsopdatering

Rapporteret den:
21. feb 2020
Berørte pakker:
python-pysaml2
Sårbar:
Ja
Referencer i sikkerhedsdatabaser:
I Mitres CVE-ordbog: CVE-2020-5390.
Yderligere oplysninger:

Man opdagede at pysaml2, en Python-implementering af SAML til anvendelse i et WSGI-miljø, var sårbar over for angreb i forbindelse med XML-signaturindpakning, hvilket kunne medføre omgåelse af signaturverifikation.

I den gamle stabile distribution (stretch), er dette problem rettet i version 3.0.0-5+deb9u1.

I den stabile distribution (buster), er dette problem rettet i version 5.4.1-2+deb10u1.

Vi anbefaler at du opgraderer dine python-pysaml2-pakker.

For detaljeret sikkerhedsstatus vedrørende python-pysaml2, se dens sikkerhedssporingsside på: https://security-tracker.debian.org/tracker/python-pysaml2