Рекомендация Debian по безопасности

DSA-4637-1 network-manager-ssh -- обновление безопасности

Дата сообщения:
09.03.2020
Затронутые пакеты:
network-manager-ssh
Уязвим:
Да
Ссылки на базы данных по безопасности:
В каталоге Mitre CVE: CVE-2020-9355.
Более подробная информация:

Кобус ван Шоор обнаружил, что network-manager-ssh, дополнение для NetworkManager, предоставляющее интеграцию VPN для SSH, уязвимо к повышению привилегий. Локальный пользователь с правами на изменение соединений может использовать эту уязвимость для выполнения команд от лица суперпользователя.

В данном обновлении прекращена поддержка передачи дополнительных опций SSH при вызове ssh.

В предыдущем стабильном выпуске (stretch) эта проблема была исправлена в версии 1.2.1-1+deb9u1.

В стабильном выпуске (buster) эта проблема была исправлена в версии 1.2.10-1+deb10u1.

Рекомендуется обновить пакеты network-manager-ssh.

С подробным статусом поддержки безопасности network-manager-ssh можно ознакомиться на соответствующей странице отслеживания безопасности по адресу https://security-tracker.debian.org/tracker/network-manager-ssh