Bulletin d'alerte Debian

DSA-4650-1 qbittorrent -- Mise à jour de sécurité

Date du rapport :
2 avril 2020
Paquets concernés :
qbittorrent
Vulnérabilité :
Oui
Références dans la base de données de sécurité :
Dans le système de suivi des bogues Debian : Bogue 932539.
Dans le dictionnaire CVE du Mitre : CVE-2019-13640.
Plus de précisions :

Miguel Onoro a signalé que qbittorrent, un client pour BitTorrent avec une interface graphique en Qt5, permet une injection de commandes à l'aide de métacaractères de l’interpréteur de commande dans le paramètre de nom de torrent ou dans le paramètre du « tracker » actuel, ce qui pourrait avoir pour conséquence l'exécution de commandes à distance à l'aide d'un nom contrefait dans un flux RSS si qbittorrent est configuré pour exécuter un programme externe à l'achèvement du chargement d'un torrent.

Pour la distribution oldstable (Stretch), ce problème a été corrigé dans la version 3.3.7-3+deb9u1.

Pour la distribution stable (Buster), ce problème a été corrigé dans la version 4.1.5-1+deb10u1.

Nous vous recommandons de mettre à jour vos paquets qbittorrent.

Pour disposer d'un état détaillé sur la sécurité de qbittorrent, veuillez consulter sa page de suivi de sécurité à l'adresse : https://security-tracker.debian.org/tracker/qbittorrent.