Рекомендация Debian по безопасности

DSA-4650-1 qbittorrent -- обновление безопасности

Дата сообщения:
02.04.2020
Затронутые пакеты:
qbittorrent
Уязвим:
Да
Ссылки на базы данных по безопасности:
В системе отслеживания ошибок Debian: Ошибка 932539.
В каталоге Mitre CVE: CVE-2019-13640.
Более подробная информация:

Мигель Оноро сообщил, что qbittorrent, bittorrent-клиент с графическим пользовательским интерфейсом на основе Qt5, позволяет выполнять введение команд с помощью метасимволов командной оболочки в параметре имени торрента или параметре текущего трекера, что может приводить к удалённому выполнению команд через специально сформированное имя в RSS-ленте в случае, если qbittorrent настроен на запуск внешней программы по завершению загрузки торрента.

В предыдущем стабильном выпуске (stretch) эта проблема была исправлена в версии 3.3.7-3+deb9u1.

В стабильном выпуске (buster) эта проблема была исправлена в версии 4.1.5-1+deb10u1.

Рекомендуется обновить пакеты qbittorrent.

С подробным статусом поддержки безопасности qbittorrent можно ознакомиться на соответствующей странице отслеживания безопасности по адресу https://security-tracker.debian.org/tracker/qbittorrent